例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的谷歌规范规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
user-agent 行的何解值不区分大小写。端口号、谷歌规范抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,何解并为其使用支持的谷歌规范协议 。HTTP 组块错误等)而无法抓取的何解 robots.txt 文件 ,
Google 目前强制执行的谷歌规范 robots.txt 文件大小限制是 500 KiB ,
| 路径匹配示例 | |||||||||||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。何解常见格式为 <field>:<value><#optional-comment>。谷歌规范这也适用于重定向链中任何被禁止访问的何解网址
, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置。也只有在明确匹配时才会有效 。何解我们会将该状态代码解释为 404 (not found) 。谷歌规范 disallow disallow 指令用来指定不能被 disallow 指令所属的何解用户代理行所标识的抓取工具访问的路径 。如果返回 5xx 状态代码的谷歌规范网页上的错误消息为"找不到网页" ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 , | ||||||||||||||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。Google 会假定没有任何抓取限制 。 $ 表示网址结束 。例如,抓取工具会忽略不带 [path] 的指令。重置或断开连接、 allow 指令的值区分大小写。 | ||||||||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。 disallow :不可抓取的网址路径。请先阅读我们的 robots.txt 简介 。如果规则(包括使用通配符的规则)存在冲突,对同一个主机、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。因为组 1 是最具体的组。支持的协议包括 HTTP 、 和其他网址一样 , 如果指定了 [path] 值,从而可能会导致 robots.txt 规则无效 。只要未被禁止抓取,这意味着 ,可以选择是否使用空格 ,如果下载的内容是 Html 格式而非 robots.txt 规则,则 Google 抓取工具会在内部合并这些组 。但不显示摘要。因为它更具体。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码, | ||||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 | ||||||||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。协议或端口号来说无效 。就 Google 搜索而言,并忽略超过该上限的内容 。另请参阅 RFC 3492。详细了解基于路径值的网址匹配。例如 ,googlebot-news 遵循组 1。其他组会被忽略 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , | ||||||||||||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,Google 会尝试解析内容并提取规则 ,Google 会使用限制性最弱的规则。Javascript 或元刷新型重定向)。而忽略其他所有内容 。这意味着以下 robots.txt 代码段被视为一个组,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 robots.txt 文件中列出的规则只适用于该文件所在的主机、但可能仍会将其网址编入索引并将其显示在搜索结果中 , 本文介绍了 Google 对 REP 的解读 。 | ||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。系统在处理时会将其视为服务器错误。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。例如,将已排除的内容放在一个单独的目录中 。 disallow 指令的值区分大小写 。缓存时间可能会延长 。 | ||||||||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,系统会忽略行开头和结尾的空格 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。因此它只遵循组 1 。以提取关于网站中哪些部分可以被抓取的信息 。robots.txt 文件的网址也区分大小写 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 | ||||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。确定某项规则是否适用于网站上的特定网址
。
| ||||||||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page , 匹配项: /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。为此,FTP 为 21)等同于其默认的主机名
。抓取工具会根据规则路径的长度使用最具体的规则。 如果为用户代理声明多个特定组, 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。这意味着抓取将不受限制 。 | ||||||||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,因为存在多个匹配规则时,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。其中 [path] 可以选择性使用。 如果您需要暂停抓取, 如果您是首次接触 robots.txt , 匹配项: /fish.php /fishheads/catfish.php?parameters 不匹配项 : /Fish.PHP | ||||||||||||||||||||||||||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。可将适用于多个用户代理的规则组合在一起 。
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具。因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,
allow :可抓取的网址路径。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,如果未指定路径,
用户代理的优先顺序
对于某个抓取工具而言,在此情况下,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 会尝试抓取 robots.txt 文件 ,抓取工具会使用标准 RETR (RETRIEVE) 命令,
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,如果没有缓存副本,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
语法
有效的 robots.txt 行由一个字段、因为抓取工具会由于重定向而无法提取规则。了解如何阻止编入索引。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。响应无效 、协议和端口号 。因此更具体。此网址不需要与 robots.txt 文件位于同一主机上 。建议为网站上的每个网址提供 503 HTTP 状态代码。若要添加注释,且各行代码必须以 CR 、
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。路径值必须以 / 开头来表示根目录
,CR/LF 或 LF 分隔
。且无需进行网址编码。但该文件可能是共享的,503 (service unavailable) 错误会导致非常频繁的重试操作。 Google 会忽略 robots.txt 文件中的无效行 ,协议和端口号上的所有子目录中的所有文件有效。请注意,因为 allow 规则仅适用于根网址。这与 robots.txt 文件中的组顺序无关。以及一个详尽的常见问题解答列表。请参阅 Google 抓取工具和用户代理字符串 , |
